FAQFAQ  SzukajSzukaj  UżytkownicyUżytkownicy  GrupyGrupy
RejestracjaRejestracja  Galeria AvatarówGaleria Avatarów  IRC (qchat mibbit)  ZalogujZaloguj

Poprzedni temat :: Następny temat
  Problem: Udostępnianie połączenia w Kubuntu
Wersja do druku
Tyczek Płeć:Mężczyzna
♩♪♫♬


Dołączył: 04 Gru 2006
Skąd: Słupca
Status: offline
PostWysłany: 29-08-2007, 11:26   Problem: Udostępnianie połączenia w Kubuntu

Postanowiłem, że przesiąde się na kubuntu...
Mam pewien problem. Nie mogę udostępnić połączenia internetowego.

Konfiguracja przedstawia się następująco.
Moja strona (kubuntu)
Modem kablowy oznaczony jest w systemie jako eth2 z ip (85.221.238.85)

/etc/rc.local

Cytat:
#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.

echo 1 > /proc/sys/net/ipv4/ip_forward
iptables -t nat -o eth2 -j MASQUERADE

exit 0


Internet ma udostępniać karta wifi oznaczona jako wlan0, której ip nadane to 192.168.1.1
Teraz- konfiguracja /etc/network/interfaces

Cytat:
auto lo
iface lo inet loopback
address 127.0.0.1
netmask 255.0.0.0

auto eth2
iface eth2 inet dhcp
auto wlan0
iface wlan0 inet static
address 192.168.1.1
netmask 255.255.255.0
wireless-essid <kubap>
wireless-mode ad-hoc
gateway 192.168.1.1



W laptopie z windowsem ustawione jest następująco:

Cytat:
Ip: 192.168.1.2
Maska podsieci: 255.255.255.0
Brama: 192.168.1.1
DNS: 192.168.1.1


Ogólnie rzecz biorąc połączenie jest, mogę przesyłać pliki pomiędzy komputerami!
Lecz internet nie jest dostępny. Może coś źle robię. W konfiguracji w kubuntu jest takie coś jak brama internetowa, ale nie wiem czy ma być to brama ip eth2 czy wlan0
Wiem, że są tu osoby znające linuksa.
Proszę o pomoc :)

_________________
Przejdź na dół Zobacz profil autora
Zobacz profil autora Wyślij prywatną wiadomość
 
Numer Gadu-Gadu
8487137
tilk Płeć:Mężczyzna


Dołączył: 24 Lip 2003
Status: offline

Grupy:
Alijenoty
PostWysłany: 29-08-2007, 21:39   

Po pierwsze, wyrzucić gateway z konfiguracji wlan0. Po drugie, ustawienie DNS na bramę ma sens tylko wtedy, jeśli na bramie pracuje demon DNS (np. bind) obsługujący zapytania rekursywne dla sieci lokalnej (może być wymagane skonfigurowanie go).

Przydałoby się więcej informacji, mianowicie konfiguracja interfejsów (ifconfig), tablica routingu (route) oraz tabele filtru pakietowego (iptables -L, iptables -t nat -L). Można jeszcze przeprowadzić jakieś eksperymenty, np. wykonać z laptopa traceroute na jakiś znany IP, np. mój 80.55.246.78.
Powrót do góry Zobacz profil autora
Zobacz profil autora Wyślij prywatną wiadomość Wyślij email Odwiedź stronę autora Odwiedź blog autora Odwiedź galerię autora Odwiedź listę obejrzanych anime / przeczytanych mang
 
Numer Gadu-Gadu
1543661
Tyczek Płeć:Mężczyzna
♩♪♫♬


Dołączył: 04 Gru 2006
Skąd: Słupca
Status: offline
PostWysłany: 29-08-2007, 22:05   

Postanowiłem zmienić ip wlan0 na 10.0.0.1...

Dane się tak przedstawiają...

Cytat:
tyczek@tyczek-desktop:~$ ifconfig
eth0 Link encap:Ethernet HWaddr 00:30:05:2C:48:A2
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

eth1 Link encap:Ethernet HWaddr 00:0E:2E:3A:96:68
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Interrupt:17 Base address:0x400

eth2 Link encap:Ethernet HWaddr 00:11:1A:FF:85:07
inet addr:85.221.238.85 Bcast:85.221.239.255 Mask:255.255.252.0
inet6 addr: fe80::211:1aff:feff:8507/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:904 errors:0 dropped:0 overruns:0 frame:0
TX packets:866 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:480454 (469.1 KiB) TX bytes:145620 (142.2 KiB)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:1 errors:0 dropped:0 overruns:0 frame:0
TX packets:1 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:88 (88.0 b) TX bytes:88 (88.0 b)

wlan0 Link encap:Ethernet HWaddr 00:12:0E:49:97:D2
inet addr:10.0.0.1 Bcast:10.0.0.255 Mask:255.255.255.0
inet6 addr: fe80::212:eff:fe49:97d2/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:115 errors:0 dropped:0 overruns:0 frame:0
TX packets:111 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:12451 (12.1 KiB) TX bytes:11933 (11.6 KiB)
Interrupt:20 Memory:d0101000-d0101025


Cytat:
tyczek@tyczek-desktop:~$ route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
10.0.0.0 * 255.255.255.0 U 0 0 0 wlan0
85.221.236.0 * 255.255.252.0 U 0 0 0 eth2
link-local * 255.255.0.0 U 1000 0 0 wlan0
default c236-1.icpnet.p 0.0.0.0 UG 0 0 0 eth2


Cytat:
tyczek@tyczek-desktop:~$ sudo iptables -L
Chain INPUT (policy ACCEPT)
target prot opt source destination

Chain FORWARD (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)
target prot opt source destination


Cytat:
tyczek@tyczek-desktop:~$ sudo iptables -t nat -L
Chain PREROUTING (policy ACCEPT)
target prot opt source destination

Chain POSTROUTING (policy ACCEPT)
target prot opt source destination
MASQUERADE 0 -- anywhere anywhere

Chain OUTPUT (policy ACCEPT)
target prot opt source destination


Nie wiem czy dobrze jest skrypt stworzony (rc.local)...

_________________
Powrót do góry Zobacz profil autora
Zobacz profil autora Wyślij prywatną wiadomość
 
Numer Gadu-Gadu
8487137
tilk Płeć:Mężczyzna


Dołączył: 24 Lip 2003
Status: offline

Grupy:
Alijenoty
PostWysłany: 29-08-2007, 23:04   

Tyczek napisał/a:
Nie wiem czy dobrze jest skrypt stworzony (rc.local)...


Prawdę mówiąc, to jest błąd... Winno być: iptables -t nat -A POSTROUTING -o eth2 -j MASQUERADE. Ale dziwnym trafem wpis w iptables jest... Sprawę z ip_forward zwykle załatwiałem inaczej, zmieniając linijkę ip_forward na yes w /etc/network/options. Tu też powinno tak się dać, *Ubuntu ma z Debianem dużo wspólnego.

Inna wątpliwość jest taka - czy w ogóle skrypt rc.local jest używany w Ubuntu? W Debianie nie jest... Choć domyślam się, że uruchomiłeś go ręcznie, więc to też nie ma związku z problemem.

W każdym razie, żadnych większych problemów nie widzę. Hm.
Powrót do góry Zobacz profil autora
Zobacz profil autora Wyślij prywatną wiadomość Wyślij email Odwiedź stronę autora Odwiedź blog autora Odwiedź galerię autora Odwiedź listę obejrzanych anime / przeczytanych mang
 
Numer Gadu-Gadu
1543661
Tyczek Płeć:Mężczyzna
♩♪♫♬


Dołączył: 04 Gru 2006
Skąd: Słupca
Status: offline
PostWysłany: 29-08-2007, 23:24   

Poprawiłem...
/etc/network/options nie istnieje :)
Btw. ręcznie raczej nic nie dodawałem (?)
Sam już nie wiem- chyba wypada kupić router...

[EDIT]: Problem został rozwiązany poprzez zakup routera... Dziękuje Tilk za pomoc :)

_________________
Powrót do góry Zobacz profil autora
Zobacz profil autora Wyślij prywatną wiadomość
 
Numer Gadu-Gadu
8487137
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Nie możesz załączać plików
Możesz ściągać załączniki
Dodaj temat do Ulubionych


Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group